Wiki

Nat server原理与配置

Bạn đang xem: nat server原理与配置 Tại Website xmccomplex.com.vn

NAT server原理与配置

NAT server 一般在什么情况下使用?
外网访问内网的情况下,例如运维工程师远程访问server服务器
NAT server 是转换的源IP地址还是目标IP 地址?
根据数据包方向,从内网访问外网的数据包是转换源ip地址,从外网访问内网的数据包的目标ip地址
NAT server 是单向转换,还是双向转换?
属于静态NAT是双向转换,手动配置的都是静态nat
NAT server 与静态NAT的区别是什么?
nat server是静态nat的一个小类别
动态nat、 静态nat、 pat (动态pnat 【动态pnat、easyip】、静态pant也叫nat server )

5.1 问题
将内部地址10.1.1.11/24的80端口静态转换为公网地址200.1.1.11的80端口,以便被外网(Client1)访问。

将内部地址10.1.1.12/24的21端口静态转换为公网地址200.1.1.11的21端口,以便被外网(Client1)访问。

[R1-G0/0/1]nat server protocol tcp global 200.1.1.11 21 inside 10.1.1.12 21
接口 0/0/1 nat服务 协议 tcp 公网ip 内网ip
实现tcp21 ftp的访问
[R1-G0/0/1]nat server protocol icmp global 200.1.1.11 inside 10.1.1.11
实现让client1可以ping通server1

dis nat server //查看nat server配置

R2远程访问控制sw1
远程端口号是23 r1上需要nat server设置
sw1需要有ip地址 [SW1-Vlanif10]ip add 10.1.1.88 24
还需要有静态默认路由 下一跳
[SW1]ip route-static 0.0.0.0 0.0.0.0 10.1.1.254
设定远程登录
[SW1]user-interface vty 0 4
[SW1-ui-vty0-4]authentication-mode password
[SW1-ui-vty0-4]set authentication password cipher HCIE
访问密码HCIE
[R1-G0/0/1]nat server protocol tcp global 200.1.1.11 23 inside 10.1.1.88 23

telnet 200.1.1.11 //用户视图 telnet访问
实现R2可以远程访问控制sw1

配置思路:
1.配置终端设备
-ip地址网关地址
-服务器web、ftp启用
2.配置网络设备
-配置交换机-vlan 接口模式
3.配置路由器
-接口ip地址
-静态默认路由去往外网
-g0/0/1接口配置nat server
4.验证与测试

5 案例5:配置华为NAT Server
5.1 问题
将内部地址10.1.1.11/24的80端口静态转换为公网地址200.1.1.11的80端口,以便被外网(Client1)访问。

将内部地址10.1.1.12/24的21端口静态转换为公网地址200.1.1.11的21端口,以便被外网(Client1)访问。

5.2 方案
搭建实验环境,如图-1所示。

图-1

5.3 步骤
实现此案例需要按照如下步骤进行。

Server-2:
10.1.1.11
255.255.255.0
10.1.1.254
Server-3:
10.1.1.12
255.255.255.0
10.1.1.254
undo terminal
system-view
[Huawei]sysname SW
[SW]vlan 10 // 创建 VLAN 10
[SW-vlan10]quit
[SW]interface gi0/0/3 // 连接内网 R1的接口
[SW-GigabitEthernet0/0/3]port link access
[SW-GigabitEthernet0/0/3]port default vlan 10
[SW-GigabitEthernet0/0/3]quit
[SW]interface gi0/0/12 // 连接内网 Server-2的接口
[SW-GigabitEthernet0/0/12]port link access
[SW-GigabitEthernet0/0/12]port default vlan 10
[SW-GigabitEthernet0/0/12]quit
[SW]interface gi0/0/13 // 连接内网 Server-3的接口
[SW-GigabitEthernet0/0/13]port link access
[SW-GigabitEthernet0/0/13]port default vlan 10
[SW-GigabitEthernet0/0/13]quit
undo terminal
system-view
[Huawei]sysname R1
[R1]interface gi0/0/0 // 连接内网的接口
[R1-GigabitEthernet0/0/0]ip address 10.1.1.254 24
[R1-GigabitEthernet0/0/0]quit
[R1]interface gi0/0/1 // 连接外网的接口
[R1-GigabitEthernet0/0/1]ip address 200.1.1.13 28
[R1-GigabitEthernet0/0/1]quit
[R1]ip route-static 0.0.0.0 0 200.1.1.14 // 去往外网的默认路由
Client-1:
1000.1.1.1
255.255.255.0
100.1.1.254
undo terminal
system-view
[Huawei]sysname R2
[R2]interface gi0/0/0 // 连接Client-1的接口
[R2-GigabitEthernet0/0/0]ip address 100.1.1.254 24
[R2-GigabitEthernet0/0/0]quit
[R2]interface gi0/0/1 // 连接外网的接口
[R2-GigabitEthernet0/0/1]ip address 200.1.1.14 28
[R2-GigabitEthernet0/0/1]quit
interfac gi0/0/1
nat server protocol tcp global 200.1.1.11 80 inside 10.1.1.11 80
nat server protocol tcp global 200.1.1.11 21 inside 10.1.1.12 21
display nat server
Nat Server Information:
Interface : GigabitEthernet0/0/1
Global IP/Port : 200.1.1.11/80(www)
Inside IP/Port : 10.1.1.11/80(www)
Protocol : 6(tcp)
(……)
Global IP/Port : 200.1.1.11/21(ftp)
Inside IP/Port : 10.1.1.12/21(ftp)
Protocol : 6(tcp)
(……)

Xem thêm :  Khi con gái im lặng trong tình yêu là lúc chàng nhất định phải chủ động níu giữ


NAT Explained – Network Address Translation


What is NAT? This is an animated video tutorial explaining how NAT works (network address translation). What’s the difference between a public IP address and private IP address? What’s the difference between IPv4 vs IPv6?

Xem thêm bài viết thuộc chuyên mục: Wiki

Related Articles

Back to top button